Wednesday, March 19, 2008

Netbeans 6.1 Beta

I've downloaded the latest Netbeans 6.1 beta release and installed it on my Mac today. I haven't had too much time to work with it as yet, but thus far I have found the following to be nice:

- No need to manually set up libraries or import projects, ALL of my settings from 6.0.1 have been imported successfully!

- Javascript support is nice

- Startup time has been greatly reduced!

These are some of the improvements I've seen within the last few minutes of looking around. It also seems like my applications build faster and deploy to Glassfish V2 with improved speed...

I have found one negative point so far...Facelets support is completely gone from what I can see. My facelets support plugin https://nbfaceletssupport.dev.java.net/ which worked in 6.0.1 does not load anymore. All XHTML documents now look like plain old JSP...but I cannot say whether code completion for facelets will work or not as I have not really had a chance to test thus far.

If you are looking to see improvements and don't mind losing the facelets plugin support, I recommend giving it a try.

11 comments:

Chhandomay said...

Hi Josh,

Thanks for trying NetBeans 6.1 Beta and your feedback -- these are very valuable to us.

One quick note. From what I understand, we never had Facelets support in the standard distribution of NetBeans. We did not have it available on the update center either.

What we did have is this plugin, available for download from java.net: https://nbfaceletssupport.dev.java.net/

According to the project page, the plugin works with NetBeans 6.0.

Are you suggesting that this plugin has stopped working with NetBeans 6.1 Beta?

Thanks
Chhandomay

Josh Juneau said...

Hi Chhandomay, thanks for the comment.

Yes, the plugin which is available from nbfaceletssupport does not function with Netbeans 6.1. As a matter of fact, it doesn't install. When I go to the plugin manager and attempt to install the facelets plugin, I receive the following errors:

Missing required modules for Plugin Facelets Support:
JSP Editor [module org.netbeans.modules.web.core.syntax/1 > 1.23.29] JSP Parser [module org.netbeans.modules.web.jspparser/2 > 2.6.21]
Missing required modules for Plugin Simple JSF/Facelets Snippets:
JSP Editor [module org.netbeans.modules.web.core.syntax/1 > 1.23.29]

I am unable to make the plugin install at this point.

Even though the facelets plugin will not work at this time, it still is worth the upgrade for the other new features.

Thanks

Muraliz said...

Me too, facing the same issue. Don't know if anything could be done for this. I had even tried with on the dev builds of 6.0.1 beta, the same error is coming.

Anonymous said...

me too, I'm waiting for a working plugin in order to adopt NB 6.1

Alfarod said...

I have the same issue. Somehow it does not work anymore.

Scott said...

Yes, the lose of Facelets support is quite disappointing especially since it was on the roadmap to be included in the base ide. But even if it did drop of the list as a P3 issue, perhaps an attempt to recompile the facelets plugin could be made for 6.1 in the meanwhile. Hopefully 6.5 in four months time will see facelets support return as rumours abound of JSF 2.0 to include facelets style in some form, but I suspect a minority are pushing the jsftemplating project instead.

Anonymous said...

i've tryed to recompile the nbfaceletssupport using this link: https://nbfaceletssupport.dev.java.net/howToBuild.html

but this is for nb5.5.1 and my try was unsuccesful because of missing libraryes

Is there any way to get nbfacelets support in nb6.1?

I need nb6.1, because it can handle libraries included into project(i'm using with svn) properly

nevster said...

I finally got it working by hacking the nbm.
Get the nbm file here http://nbfaceletssupport.dev.java.net/files/documents/5684/99000/nbfaceletssupport-6.1.zip

Edit info.xml - search for jspparser and replace the date to 200807041025

Then also open up the internal jar file and edit the MANIFEST.MF file and do the same replacement.

Zip it all back up and do the manual install.

Marcio Wesley Borges said...

Hi guys,

About the error message:
"Missing required modules for Plugin Facelets Support:
JSP Parser [module org.netbeans.modules.web.jspparser/3 = 200804211638]"

I had (and also many people, too) the same problem when trying to install Facelets plugin into Netbeans 6.1. After many think, trying and search, I found the solution here: nevster comment. Thank you very much nevster!

I patched the Facelets module (only good to Netbeans 6.xxx FCS, no ML) and if you want download it, it's here: nbfaceletssupport-6.1.zip

More information can be found at: Facelets com o Netbeans 6.1

Regards,
Marcio Wesley Borges
http://www.marciowb.net/blog/

Josh Juneau said...

Thanks to everyone who has been following this post. It is great to have the Facelets plugin for 6.1 at last! Nevster...we really appreciate it!

On another note, I am on the NetCAT 6.5 team and I will put in a request for enhancement to see if we can get the Facelets plugin integrated into Netbeans sometime soon. It think that would benefit many people.

Alejo Ceballos said...

Nevster, I thank you very much... You have solved the problem. I have been looking for a solution to this for hours and you were the only one to get it done.

Again, thank you very much!